Question about gazebo on web


I know this is kinda repeat subject.

So, there’s two different between gazeboapp-sim and gzweb2. I was able to load gazeboapp-sim just by follow the instructions. Everything went well until I load it in localhost:3000 and that was it. I can’t see anything. It says it needs domain option required. I don’t even know where to look into it.

I thought it needed websocket so I made a file with exact name and content inside gz-launch/websocket.gzlaunch at gz-launch6 · gazebosim/gz-launch · GitHub

then ran the gazebo along with the websocket launch while gazeboapp-sim is still on. it doesn’t seem like they all are connected at all. When I changed the port from 9000 to 3000, it caused some conflict with gazeboapp-sim’s port.

So, I tried gzweb. It said it needs npm as 8v and node as 14 but i can only get node as 14 and npm as 6. When I move the npm from 6 to 8, node will end up be 16.

I did try and continue with npm v6 and node as 14.

Only npm run test is having issue but everything else was complied smoothly. There is no way for me to start gzweb though.

So I guess the question is where do I start and have gazebo on web to run so i can use m2 on apple or windows 8 on my pc to run gazebo?

Chatgpt and I worked on this together for an hour.