Ardupilot_gazebo not working

I have installed gazebo garden on Ubuntu 22.04 per the instructions at :

I then installed the ardupilot_gazebo plugin as per :

However, when I test the install using

gz sim -v4 -r iris_runway.sdf

the following error arises

[Wrn] [] Fuel world download failed because Fetch failed. Other errors
Unable to find or download file

I am guessing the environment has not been configured correctly and looking for any suggestions.

open your bashrc with gedit ~/.bashrc

add to end of the file correct path to the models directory.

export GAZEBO_MODEL_PATH=/path/to/ardupilot_gazebo/models

reload bashrc

This did not work. But below is what did get the gazebo sim to work. However, when I then run the plugin vehicle in ardupilot “”, the simulation model does not follow commands.

export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/snap/bin:/snap/bin:/home/jax200/.local/bin

export GZ_SIM_SYSTEM_PLUGIN_PATH=$HOME/drone/ardupilot_gazebo/build:${GZ_SIM_SYSTEM_PLUGIN_PATH}

export GZ_SIM_RESOURCE_PATH=$HOME/drone/ardupilot_gazebo/models:$HOME/drone/ardupilot_gazebo/worlds:${GZ_SIM_RESOURCE_PATH}

Hi @jax2000, if you run with full logging:

gz sim -v4 iris_runway.sdf

what are you seeing in the console? Similarly what is the output from the MAVProxy terminal running: -v ArduCopter -f gazebo-iris --model JSON --map

and the SITL window that pops up separately? If you can see the iris on the runway then it’s most likely a problem the connection or version of ArduPilot that you’re running (you’ll generally want to run master).

Thank you for responding.

gz sim -v4 iris_runway.sdf

what are you seeing in the console?

I see the iris copter on the runway.

what is the output from the MAVProxy terminal running:…

It shows “No JSON sensor message received, resending servos”

and “MAV> link 1 down”

If I run the simple --map --console it connects ok and I can send mavproxy commands, but there is no response from the gazebo vehicle.

It is now working if I run the SITL first and be patient for the gazebo sim to work.